Our mobile app is built and tested for Android or iOS devices only and can be found on the Google Play and the App Store. To be able to run the app, your device will need to meet these requirements:

Android

  • compatible with a phone or tablet running on version 4.4 or later

iOS

  • compatible with an iPhone, iPad, or iPod touch running on version 10 or later


Still need further assistance? Why not check out our Angelcam Community, where you can connect with other users who are sharing their own experiences and insight into various Angelcam topics and problems.

Did this answer your question?